Creates a new angular dimension object using the default dimension type.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DB View
The view in which the dimension is to be visible.
- arc
- Type: Autodesk.Revit.DB Arc
The extension arc of the dimension.
- firstRef
- Type: Autodesk.Revit.DB Reference
The first geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
- secondRef
- Type: Autodesk.Revit.DB Reference
The second geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
Return Value
If creation was successful the new angular dimension is returned, otherwise an exception with failure information will be thrown.Remarks
The currently user set default style is used for the created dimension.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when any input argument is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown when the argument is invalid. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when the creation failed. |