Family |
Creates a new angular dimension object using the default dimension type.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public Dimension NewAngularDimension(
View view,
Arc arc,
Reference firstRef,
Reference secondRef
)
Parameters
- view View
- The view in which the dimension is to be visible.
- arc Arc
- The extension arc of the dimension.
- firstRef Reference
- The first geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
- secondRef Reference
- The second geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
Return Value
DimensionIf creation was successful the new angular dimension is returned, otherwise an exception with failure information will be thrown.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when any input argument is . |
ArgumentException | Thrown when the argument is invalid. |
InvalidOperationException | Thrown when the creation failed. |

The currently user set default style is used for the created dimension.