For ShapeDriven: Returns the RebarConstraint that has been set as preferred for the specified RebarConstrainedHandle.
For FreeForm: Returns the RebarConstraint that acts on the specified RebarConstraintHandle.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- handle
- Type: Autodesk.Revit.DB.Structure RebarConstrainedHandle
The RebarConstrainedHandle for which the RebarConstraint is to be returned.
Return Value
The user preferred RebarConstraint applied to the RebarConstrainedHandle.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | handle is no longer valid. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | The RebarConstraintsManager does not manage a valid Rebar element. |