Rebar |
For ShapeDriven: Returns the RebarConstraint that has been set as preferred for the specified RebarConstrainedHandle.
For FreeForm: Returns the RebarConstraint that acts on the specified RebarConstraintHandle.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- handle RebarConstrainedHandle
- The RebarConstrainedHandle for which the RebarConstraint is to be returned.
Return Value
RebarConstraintThe user preferred RebarConstraint applied to the RebarConstrainedHandle.

Exception | Condition |
---|---|
ArgumentException | handle is no longer valid. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The RebarConstraintsManager does not manage a valid Rebar element. |