GetEndPointReference Method


Returns a stable reference to the start point or the end point of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014

Syntax

C#
public Reference GetEndPointReference(
	int index
)
Visual Basic
Public Function GetEndPointReference ( _
	index As Integer _
) As Reference
Visual C++
public:
Reference^ GetEndPointReference(
	int index
)

Parameters

index
Type: System Int32
Use 0 for the start point; 1 for the end point.

Return Value

Reference to the point or a null reference ( Nothing in Visual Basic) if reference cannot be obtained.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException Thrown when the specified index is not 0 or 1.
Autodesk.Revit.Exceptions InvalidOperationException Thrown when the object is internally marked as read-only or this curve is unbound.

See Also