Curve Get |
Returns a stable reference to the start point or the end point of the curve.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- index Int32
- Use 0 for the start point; 1 for the end point.
Return Value
ReferenceReference to the point or if reference cannot be obtained.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1. |
InvalidOperationException | Thrown when the object is internally marked as read-only or this curve is unbound. |