GetAssociatedElementId Method


Returns id of the element which is in association with the element with the given ElementId.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2023

Syntax

C#
public ElementId GetAssociatedElementId(
	ElementId elementId
)
Visual Basic
Public Function GetAssociatedElementId ( _
	elementId As ElementId _
) As ElementId
Visual C++
public:
ElementId^ GetAssociatedElementId(
	ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB ElementId
Element id for which we want to get the associated element.

Return Value

Id of the associated element.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also