Returns the parameters that are not among the set of filterable parameters common to the given categories.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDoc
- Type: Autodesk.Revit.DB Document
The document containing the categories and parameters to query.
- categories
- Type: System.Collections.Generic ICollection ElementId
The categories that define the set of possibly filterable parameters.
- parameters
- Type: System.Collections.Generic IList ElementId
The parameters desired for use in a parameter filter.
Return Value
A list of parameters from the given array that are not valid for use in a parameter filter with the given categories.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |