GetInapplicableParameters Method


Returns the parameters that are not among the set of filterable parameters common to the given categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static IList<ElementId> GetInapplicableParameters(
	Document aDoc,
	ICollection<ElementId> categories,
	IList<ElementId> parameters
)
Visual Basic
Public Shared Function GetInapplicableParameters ( _
	aDoc As Document, _
	categories As ICollection(Of ElementId), _
	parameters As IList(Of ElementId) _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetInapplicableParameters(
	Document^ aDoc, 
	ICollection<ElementId^>^ categories, 
	IList<ElementId^>^ parameters
)

Parameters

aDoc
Type: Autodesk.Revit.DBDocument
The document containing the categories and parameters to query.
categories
Type: System.Collections.GenericICollectionElementId
The categories that define the set of possibly filterable parameters.
parameters
Type: System.Collections.GenericIListElementId
The parameters desired for use in a parameter filter.

Return Value

A list of parameters from the given array that are not valid for use in a parameter filter with the given categories.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also