Creates a new SchedulableField.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- fieldType
- Type: Autodesk.Revit.DB ScheduleFieldType
The type of data displayed by the field.
- parameterId
- Type: Autodesk.Revit.DB ElementId
The ID of the parameter displayed by the field.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | fieldType is not a schedulable field type |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |