Creates a new SchedulableField.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- fieldType
- Type: Autodesk.Revit.DBScheduleFieldType
The type of data displayed by the field.
- parameterId
- Type: Autodesk.Revit.DBElementId
The ID of the parameter displayed by the field.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | fieldType is not a schedulable field type -or- The fieldType can't be CustomField. To create a CustomField, you should use the constructor which receives the custom field server id as a parameter. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |