Creates a Surface object coincident with the ruled surface joining a bounded generating curve to a point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- profileCurve
- Type: Autodesk.Revit.DB Curve
The profile curve; must be bounded and non-degenerate.
- point
- Type: Autodesk.Revit.DB XYZ
The point. Expected to lie within the Revit design limits IsWithinLengthLimits(XYZ) .
Return Value
The created surface. Note that this surface may not be of type RuledSurf.Remarks
The returned surface may not be of type RuledSurf - this function will create a surface of the simplest possible type (Plane, CylindricalSurface, etc.) that can be used to represent the given ruled surface. Given that the surface may be simplified, this function does not guarantee any particular parameterization of the surface.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input profileCurve is not bound. -or- The profileCurve is degenerate (its length is too close to zero). -or- The input point lies outside of Revit design limits. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |