Ruled |
Creates a Surface object coincident with the ruled surface joining a bounded generating curve to a point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- profileCurve Curve
- The profile curve; must be bounded and non-degenerate.
- point XYZ
- The point. Expected to lie within the Revit design limits IsWithinLengthLimits(XYZ) .
Return Value
SurfaceThe created surface. Note that this surface may not be of type RuledSurf.

Exception | Condition |
---|---|
ArgumentException | The input profileCurve is not bound. -or- The profileCurve is degenerate (its length is too close to zero). -or- The input point lies outside of Revit design limits. |
ArgumentNullException | A non-optional argument was null |

The returned surface may not be of type RuledSurf - this function will create a surface of the simplest possible type (Plane, CylindricalSurface, etc.) that can be used to represent the given ruled surface. Given that the surface may be simplified, this function does not guarantee any particular parameterization of the surface.