GetExternallyTaggedGeometry Method


Gets the externally tagged geometry by its external ID that is stored in this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public ExternallyTaggedGeometryObject GetExternallyTaggedGeometry(
	ExternalGeometryId externalId
)
Visual Basic
Public Function GetExternallyTaggedGeometry ( _
	externalId As ExternalGeometryId _
) As ExternallyTaggedGeometryObject
Visual C++
public:
ExternallyTaggedGeometryObject^ GetExternallyTaggedGeometry(
	ExternalGeometryId^ externalId
)

Parameters

externalId
Type: Autodesk.Revit.DB ExternalGeometryId
The external ID of the externally tagged geometry that should be obtained.

Return Value

The externally tagged geometry. Or a null reference ( Nothing in Visual Basic) if there is no such an externally tagged geometry in the DirectShapeType.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also