Gets the externally tagged geometry by its external ID that is stored in this DirectShapeType.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- externalId
- Type: Autodesk.Revit.DBExternalGeometryId
The external ID of the externally tagged geometry that should be obtained.
Return Value
The externally tagged geometry. Or a null reference (Nothing in Visual Basic) if there is no such externally tagged geometry in the DirectShapeType.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |