Sets path information identifying where Revit searches for content.
Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- paths
- Type: System.Collections.Generic IDictionary String , String
The map of library paths.
Remarks
The map that is returned should contain a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path to be used for that search path.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |