SetLibraryPaths Method


Application Set Library Paths Method

Sets path information identifying where Revit searches for content.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetLibraryPaths(
	IDictionary<string, string> paths
)

Parameters

paths IDictionary String , String
The map of library paths.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
The map that is returned should contain a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path to be used for that search path.
See Also