Updates the specified paths of travel by recalculating each path using their original start and end points and provides creation result statuses.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2020
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- adoc
- Type: Autodesk.Revit.DB Document
Document of elements to be updated.
- elementsToUpdate
- Type: System.Collections.Generic IList ElementId
The list of ElementId of the paths to update.
- resultStatus
- Type: System.Collections.Generic IList PathOfTravelCalculationStatus %
Result statuses of each path of travel creation. The order of statuses corresponds to the order of elements in the array passed to the function.
Return Value
number of successfully updated elementsRemarks
For unsuccessfully updated elements, Revit will post warnings.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | This functionality is not available in Revit LT. |