UpdateMultiple Method (Document, IList(ElementId), IList(PathOfTravelCalculationStatus))


Updates the specified paths of travel by recalculating each path using their original start and end points and provides creation result statuses.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2020

Syntax

C#
public static int UpdateMultiple(
	Document adoc,
	IList<ElementId> elementsToUpdate,
	out IList<PathOfTravelCalculationStatus> resultStatus
)
Visual Basic
Public Shared Function UpdateMultiple ( _
	adoc As Document, _
	elementsToUpdate As IList(Of ElementId), _
	<OutAttribute> ByRef resultStatus As IList(Of PathOfTravelCalculationStatus) _
) As Integer
Visual C++
public:
static int UpdateMultiple(
	Document^ adoc, 
	IList<ElementId^>^ elementsToUpdate, 
	[OutAttribute] IList<PathOfTravelCalculationStatus>^% resultStatus
)

Parameters

adoc
Type: Autodesk.Revit.DBDocument
Document of elements to be updated.
elementsToUpdate
Type: System.Collections.GenericIListElementId
The list of ElementIdof the paths to update.
resultStatus
Type: System.Collections.GenericIListPathOfTravelCalculationStatus%
Result statuses of each path of travel creation. The order of statuses corresponds to the order of elements in the array passed to the function.

Return Value

number of successfully updated elements

Remarks

For unsuccessfully updated elements, Revit will post warnings.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException This functionality is not available in Revit LT.

See Also