Returns a collection of leaf FolderItemInfo objects each containing the given element Id.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- elementId
- Type: Autodesk.Revit.DB ElementId
Element id located at a leaf position in the project browser.
Return Value
An array of FolderItemInfo objects.Remarks
Each returned FolderItemInfo includes the folder name and the corresponding folder parameter Id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | elementId is not a valid Element identifier. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |