Browser |
Returns a collection of leaf FolderItemInfo objects each containing the given element Id.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- elementId ElementId
- Element id located at a leaf position in the project browser.
Return Value
IList FolderItemInfoAn array of FolderItemInfo objects.

Exception | Condition |
---|---|
ArgumentException | elementId is not a valid Element identifier. |
ArgumentNullException | A non-optional argument was null |

Each returned FolderItemInfo includes the folder name and the corresponding folder parameter Id.