Gets the value of the apparent load parameter for a spare
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- row
- Type: System Int32
A row where the valid spare is
- column
- Type: System Int32
A column where the valid spare is
- idLoadParameter
- Type: Autodesk.Revit.DB ElementId
One of 4 valid load parameters: RBS_ELEC_APPARENT_LOAD, RBS_ELEC_APPARENT_LOAD_PHASEA, RBS_ELEC_APPARENT_LOAD_PHASEB, RBS_ELEC_APPARENT_LOAD_PHASEC
Return Value
The value of the spare's load parameterExceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The load parameter id is not valid. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentsInconsistentException | The row column combination does not represent a valid spare. |