GetBuildingConstructionSetElementId Method


Id of the building construction set.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011

Syntax

C#
public static ElementId GetBuildingConstructionSetElementId(
	Document ccda
)
Visual Basic
Public Shared Function GetBuildingConstructionSetElementId ( _
	ccda As Document _
) As ElementId
Visual C++
public:
static ElementId^ GetBuildingConstructionSetElementId(
	Document^ ccda
)

Parameters

ccda
Type: Autodesk.Revit.DB Document

Return Value

Returns the id of the building construction set.

Remarks

The building construction set is the default project construction set used when spaces are not assigned a construction.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also