GetBuildingConstructionSetElementId Method


Id of the building construction set.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static ElementId GetBuildingConstructionSetElementId(
	Document ccda
)
Visual Basic
Public Shared Function GetBuildingConstructionSetElementId ( _
	ccda As Document _
) As ElementId
Visual C++
public:
static ElementId^ GetBuildingConstructionSetElementId(
	Document^ ccda
)

Parameters

ccda
Type: Autodesk.Revit.DBDocument

Return Value

Returns the id of the building construction set.

Remarks

The building construction set is the default project construction set used when spaces are not assigned a construction.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also