IsTimeIntervalValid Method


Checks whether the time interval is valid for the SunAndShadowType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011

Syntax

C#
public bool IsTimeIntervalValid(
	SunStudyTimeInterval interval
)
Visual Basic
Public Function IsTimeIntervalValid ( _
	interval As SunStudyTimeInterval _
) As Boolean
Visual C++
public:
bool IsTimeIntervalValid(
	SunStudyTimeInterval interval
)

Parameters

interval
Type: Autodesk.Revit.DB SunStudyTimeInterval
Time interval value.

Return Value

True if the time interval is valid for the current SunAndShadowType, false otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also