Sun |
Checks whether the time interval is valid for the SunAndShadowType.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- interval SunStudyTimeInterval
- Time interval value.
Return Value
BooleanTrue if the time interval is valid for the current SunAndShadowType, false otherwise.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |