Gets the discipline for a given measurable spec.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- specTypeId
- Type: Autodesk.Revit.DB ForgeTypeId
Identifier of the measurable spec.
Return Value
Identifier of the discipline.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |