Unit |
Gets the discipline for a given measurable spec.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- specTypeId ForgeTypeId
- Identifier of the measurable spec.
Return Value
ForgeTypeIdIdentifier of the discipline.

Exception | Condition |
---|---|
ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). |
ArgumentNullException | A non-optional argument was null |