Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection of an arbitrary point in project space.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- modelLocation
- Type: Autodesk.Revit.DB XYZ
A point in project coordinates that will be projected to the slab top or bottom face.
- floorFace
- Type: Autodesk.Revit.DB FloorFace
A flag determining whether the top or bottom face of the floor should be used.
Return Value
Slab surface point for the vertically projected model point.Remarks
If the floor is shape edited, the surface location must be within the boundaries of a face on the slab. Otherwise the method will return a null reference ( Nothing in Visual Basic) .