Floor Get |
Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection of an arbitrary point in project space.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- modelLocation XYZ
- A point in project coordinates that will be projected to the slab top or bottom face.
- floorFace FloorFace
- A flag determining whether the top or bottom face of the floor should be used.
Return Value
XYZSlab surface point for the vertically projected model point.

If the floor is shape edited, the surface location must be within the boundaries of a face on the slab. Otherwise the method will return .