Sets the underlay base and underlay top to the specified levels.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- baseLevelId
- Type: Autodesk.Revit.DB ElementId
The element id of a level in the project or InvalidElementId. If InvalidElementId, then the underlay base level is not set and no elements will be displayed as underlay.
- topLevelId
- Type: Autodesk.Revit.DB ElementId
The element id of a level in the project or InvalidElementId. If InvalidElementId, then the underlay range is unbounded.
Examples

private void ViewUnderlay(ViewPlan planView, ElementId topLevelId, ElementId baseLevelId)
{
if (planView.GetUnderlayOrientation() == UnderlayOrientation.LookingDown)
{
if (planView.GetUnderlayTopLevel() != topLevelId)
{
planView.SetUnderlayRange(baseLevelId, topLevelId);
}
planView.SetUnderlayOrientation(UnderlayOrientation.LookingUp);
}
}

Private Sub ViewUnderlay(planView As ViewPlan, topLevelId As ElementId, baseLevelId As ElementId)
If planView.GetUnderlayOrientation() = UnderlayOrientation.LookingDown Then
If planView.GetUnderlayTopLevel() <> topLevelId Then
planView.SetUnderlayRange(baseLevelId, topLevelId)
End If
planView.SetUnderlayOrientation(UnderlayOrientation.LookingUp)
End If
End Sub
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The ElementId baseLevelId does not correspond to a Level in the project. -or- The ElementId topLevelId does not correspond to a Level in the project. -or- The elevation of level topLevelId must be greater than the elevation of level baseLevelId. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |