SetUnderlayRange Method


View Plan Set Underlay Range Method

Sets the underlay base and underlay top to the specified levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetUnderlayRange(
	ElementId baseLevelId,
	ElementId topLevelId
)

Parameters

baseLevelId ElementId
The element id of a level in the project or InvalidElementId. If InvalidElementId, then the underlay base level is not set and no elements will be displayed as underlay.
topLevelId ElementId
The element id of a level in the project or InvalidElementId. If InvalidElementId, then the underlay range is unbounded.
Exceptions
Exception Condition
ArgumentException The ElementId baseLevelId does not correspond to a Level in the project. -or- The ElementId topLevelId does not correspond to a Level in the project. -or- The elevation of level topLevelId must be greater than the elevation of level baseLevelId.
ArgumentNullException A non-optional argument was null
See Also