CreateFromCenterline Method


Create fabrication routing end from centreline point on straight element.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017

Syntax

C#
public static FabricationPartRouteEnd CreateFromCenterline(
	Element element,
	XYZ ptAt
)
Visual Basic
Public Shared Function CreateFromCenterline ( _
	element As Element, _
	ptAt As XYZ _
) As FabricationPartRouteEnd
Visual C++
public:
static FabricationPartRouteEnd^ CreateFromCenterline(
	Element^ element, 
	XYZ^ ptAt
)

Parameters

element
Type: Autodesk.Revit.DB Element
The straight element that the centerline is on.
ptAt
Type: Autodesk.Revit.DB XYZ
A point along the straight element where the fitting to be cut in should be positioned.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also