Fabrication |
Create fabrication routing end from centerline point on straight element.
Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static FabricationPartRouteEnd CreateFromCenterline(
Element element,
XYZ ptAt
)
Parameters
- element Element
- The straight element that the centerline is on.
- ptAt XYZ
- A point along the straight element where the fitting to be cut in should be positioned.
Return Value
FabricationPartRouteEnd
Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |