Generates full geometry for the Rebar for a specific view.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DB View
The view in which the geometry is generated.
Return Value
The generated geometry of the Rebar before cutting is applied.Remarks
The result of this method differs from Element.Geometry in that Element.Geometry will return the rebar geometry cut by the view extents (such as the section box). In this method the entire Rebar geometry is returned for the given view, before cutting.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |