Rebar Get |
Generates full geometry for the Rebar for a specific view.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- view View
- The view in which the geometry is generated.
Return Value
GeometryElementThe generated geometry of the Rebar before cutting is applied.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

The result of this method differs from Element.Geometry in that Element.Geometry will return the rebar geometry cut by the view extents (such as the section box). In this method the entire Rebar geometry is returned for the given view, before cutting.