Temperature Property


The custom color temperature value.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public double Temperature { get; set; }
Visual Basic
Public Property Temperature As Double
	Get
	Set
Visual C++
public:
property double Temperature {
	double get ();
	void set (double value);
}

Field Value

The color temperature in Kelvin as a numerical value between 1800 and 20000

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: The color temperature is not valid because it is not in the range of 1800 to 20000.

See Also