The base class for the event arguments used by the DialogBoxShowing event.
Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2010
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
The actual type of the event arguments will be different depending upon the type of dialog shown. When the application receives this object, a dialog is to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.
Inheritance Hierarchy
System Object
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPreEventArgs
Autodesk.Revit.UI.Events DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events MessageBoxShowingEventArgs
Autodesk.Revit.UI.Events TaskDialogShowingEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPreEventArgs
Autodesk.Revit.UI.Events DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events MessageBoxShowingEventArgs
Autodesk.Revit.UI.Events TaskDialogShowingEventArgs