DialogBoxShowingEventArgs Class


Dialog Box Showing Event Args Class

The base class for the event arguments used by the DialogBoxShowing event.
Inheritance Hierarchy

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DialogBoxShowingEventArgs : RevitAPIPreEventArgs

The DialogBoxShowingEventArgs type exposes the following members.

Properties
Name Description
Public property DialogId A unique string identifier for DialogBox and TaskDialog type dialogs in Revit.
Top
Methods
Name Description
Public method OverrideResult Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
Top
Remarks
The actual type of the event arguments will be different depending upon the type of dialog shown. When the application receives this object, a dialog is to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.
See Also