DialogBoxShowingEventArgs Class


Dialog Box Showing Event Args Class

The base class for the event arguments used by the DialogBoxShowing event.
Inheritance Hierarchy

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DialogBoxShowingEventArgs : RevitAPIPreEventArgs

The DialogBoxShowingEventArgs type exposes the following members.

Properties
Name Description
Public property Cancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitAPIEventArgs )
Public property DialogId A unique string identifier for DialogBox and TaskDialog type dialogs in Revit.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RevitAPIEventArgs )
Top
Methods
Name Description
Public method Cancel When the event is cancellable, may call the Cancel() method to cancel it.
(Inherited from RevitAPIPreEventArgs )
Public method Dispose
(Inherited from RevitAPIEventArgs )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsCancelled Indicates whether the event is being cancelled.
(Inherited from RevitAPIEventArgs )
Public method OverrideResult Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The actual type of the event arguments will be different depending upon the type of dialog shown. When the application receives this object, a dialog is to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.
See Also