Set the curves into a free form Rebar. Will throw exception if the rebar has valid constraints.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curves
- Type: System.Collections.Generic IList CurveLoop
Each curve loop represents a bar in the set.
Return Value
Returns Success if everything is ok, otherwise the failure reason.Remarks
This function can fail due to following reasons:
- The array of CurveLoops is empty.
- At least one CurveLoop is empty.
- At least one CurveLoop contains an unbounded curve.
- A rebar constructed from curves can't be bent according to the bending radius.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions InvalidOperationException | This RebarFreeFormAccessor Rebar is constrained. |