Rebar |
Set the curves into a free form Rebar. Will throw exception if the rebar has valid constraints.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
Return Value
RebarFreeFormValidationResultReturns Success if everything is ok, otherwise the failure reason.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This RebarFreeFormAccessor Rebar is constrained. |

This function can fail due to following reasons:
- The array of CurveLoops is empty.
- At least one CurveLoop is empty.
- At least one CurveLoop contains an unbounded curve.
- A rebar constructed from curves can't be bent according to the bending radius.