Checks if curve loop is valid for Analytical Opening.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2023
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- loop
- Type: Autodesk.Revit.DB CurveLoop
The curve loop to be checked.
- aDoc
- Type: Autodesk.Revit.DB Document
Revit document.
- panelId
- Type: Autodesk.Revit.DB ElementId
ElementId of the AnalyticalPanel on which we create the Opening.
Return Value
Returns true if curve loop is ok, false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |