Analytical |
Checks if curve loop is valid for Analytical Opening.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool IsCurveLoopValidForAnalyticalOpening(
CurveLoop loop,
Document aDoc,
ElementId panelId
)
Parameters
- loop CurveLoop
- The curve loop to be checked.
- aDoc Document
- Revit document.
- panelId ElementId
- ElementId of the AnalyticalPanel on which we create the Opening.
Return Value
BooleanReturns true if curve loop is ok, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |