Creates a new instance of ReferencePlane.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- bubbleEnd
- Type: Autodesk.Revit.DB XYZ
The bubble end applied to reference plane.
- freeEnd
- Type: Autodesk.Revit.DB XYZ
The free end applied to reference plane.
- thirdPnt
- Type: Autodesk.Revit.DB XYZ
A third point needed to define the reference plane.
- pView
- Type: Autodesk.Revit.DB View
The specific view apply to the Reference plane.
Return Value
The newly created reference plane.Remarks
The specific view is applied to the Reference plane only for certain view types: Legend DraftingView DrawingSheet
Examples

// Build now data before creation
XYZ bubbleEnd = new XYZ(1, 0, 0); // bubble end applied to reference plane
XYZ freeEnd = new XYZ(-5, 0, 0); // free end applied to reference plane
// Third point should not be on the bubbleEnd-freeEnd line
XYZ thirdPnt = new XYZ(0, 15, 0); // 3rd point to define reference plane
// Create the reference plane in X-Y, applying the active view
ReferencePlane refPlane = document.Create.NewReferencePlane2(bubbleEnd, freeEnd, thirdPnt, document.ActiveView);

' Build now data before creation
Dim bubbleEnd As New XYZ(1, 0, 0)
' bubble end applied to reference plane
Dim freeEnd As New XYZ(-5, 0, 0)
' free end applied to reference plane
' Third point should not be on the bubbleEnd-freeEnd line
Dim thirdPnt As New XYZ(0, 15, 0)
' 3rd point to define reference plane
' Create the reference plane in X-Y, applying the active view
Dim refPlane As ReferencePlane = document.Create.NewReferencePlane2(bubbleEnd, freeEnd, thirdPnt, document.ActiveView)