NewReferencePlane2 Method


Item Factory Base New Reference Plane 2 Method

Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ReferencePlane NewReferencePlane2(
	XYZ bubbleEnd,
	XYZ freeEnd,
	XYZ thirdPnt,
	View pView
)

Parameters

bubbleEnd XYZ
The bubble end applied to reference plane.
freeEnd XYZ
The free end applied to reference plane.
thirdPnt XYZ
A third point needed to define the reference plane.
pView View
The specific view apply to the Reference plane.

Return Value

ReferencePlane
The newly created reference plane.
Remarks
The specific view is applied to the Reference plane only for certain view types: Legend DraftingView DrawingSheet
See Also