TaskDialogShowingEventArgs Class


The event arguments used by the DialogBoxShowing event when a Revit task dialog that prompts the user for some action is shown.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2010

Syntax

C#
public class TaskDialogShowingEventArgs : DialogBoxShowingEventArgs
Visual Basic
Public Class TaskDialogShowingEventArgs _
	Inherits DialogBoxShowingEventArgs
Visual C++
public ref class TaskDialogShowingEventArgs : public DialogBoxShowingEventArgs

Remarks

When the application receives this object, a task dialog is about to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

See Also