Task |
The event arguments used by the DialogBoxShowing event when a Revit task dialog that prompts the user for some action is shown.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPreEventArgs
Autodesk.Revit.UI.Events DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events TaskDialogShowingEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPreEventArgs
Autodesk.Revit.UI.Events DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events TaskDialogShowingEventArgs
Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The TaskDialogShowingEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | Message | The message that has been displayed in the dialog box. |

Name | Description | |
---|---|---|

When the application receives this object, a task dialog is about to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.