Identify a set of elements that potentially should be displaced along with a given element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
the document
- view
- Type: Autodesk.Revit.DB View
the view
- idToDisplace
- Type: Autodesk.Revit.DB ElementId
element id of element to displace
Remarks
For example, when a wall is displaced, any inserts or hosted elements should also be displaced.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |