GetAdditionalElementsToDisplace Method


Displacement Element Get Additional Elements To Displace Method

Identify a set of elements that potentially should be displaced along with a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ICollection<ElementId> GetAdditionalElementsToDisplace(
	Document document,
	View view,
	ElementId idToDisplace
)

Parameters

document Document
the document
view View
the view
idToDisplace ElementId
element id of element to displace

Return Value

ICollection ElementId
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
For example, when a wall is displaced, any inserts or hosted elements should also be displaced.
See Also