Applies a WorksetKindFilter to the collector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- worksetKind
- Type: Autodesk.Revit.DB WorksetKind
The WorksetKind of the workset.
Return Value
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.Remarks
Only worksets whose WorksetKind is an exact match to the input WorksetKind will pass the collector.
If you have an active iterator to this collector it will be stopped by this call.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |